方法1:
1. 打开文件资源管理器并输入 \\printer.cityu-dg.local。
2. 输入“username@cityu-dg.local”,并勾选 "Remember my credentials"。
3. 双击“Staff-Print-Q”添加打印机。
方法2:
某些用户在升级Windows系统或设置新笔记本电脑后,在尝试连接我们的公共打印机队列“Staff-Print-Q”时可能会遇到问题。可能出现以下错误信息:
- " 提供的凭据不足以访问此打印机。要指定新的凭据吗?"
- " 操作无法完成(Error 0x00000005)访问被拒绝 "
- "不能打印[filename],确保打印机连接正确,并使用控制面板验证打印机配置正确"
-
"
Windows无法连接到打印机。操作失败,错误0x0000011b"
原因分析
此问题是由限制用户安装或使用打印驱动程序的Windows安全设置引起的。该漏洞和微软针对该漏洞的安全更新统称为 "PrintNightmare",
官方参考为 CVE-2021–1675, CVE-2021–34527, 和 CVE-2021–34481。
解决方案(个人电脑修复)
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以管理员身份打开命令提示符
- 搜索Windows中的命令提示符
- 右键单击并选择以管理员身份运行
- 搜索Windows中的命令提示符
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运行以下命令修改必要的注册表设置:
reg add "HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows NT\Printers\PointAndPrint" /v RestrictDriverInstallationToAdministrators /t REG_DWORD /d 0 /f 重新启动计算机并尝试重新添加打印机。请按照打印机连接用户指南中的说明操作。
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如果问题仍然存在,请重复上述步骤:
- 再次执行相同的命令
- 再次重新启动计算机并尝试再次添加打印机